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Introduction

Bose ControlSpace Remote Builder software

Bose ControlSpace Remote Builder 2.4 software is a graphical user interface tool used to design, test and
deploy mobile control panels for the Bose ControlSpace Remote app.

Bose ControlSpace Remote Builder is used by system integrators to configure control panels that are sent
to the ControlSpace Remote app. Using control panel templates from within ControlSpace Remote Builder,
integrators are able to quickly create unique interfaces for wireless control of Bose networked pro audio
systems.

System designs created in ControlSpace Designer software are easily imported into ControlSpace Remote
Builder. Defined system control elements such as volume, mute, source selection, tone EQ, and parameter
sets are assigned to end-user friendly templates. Multiple app designs—each personalized for a specific
user’s control needs—can be created and tested from ControlSpace Remote Builder and sent wirelessly to
mobile devices on the network.

You can create control panels either using the built-in templates, or by using the graphical elements avail-
able in the layout mode to design customized layouts and control buttons.

« For designing with templates, see Creating Control Panels.

e For designing customized panels, see Creating Custom Layouts and Creating Custom Controls.
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Bose ControlSpace Remote app

Bose ControlSpace Remote app is a mobile device application for Android™ and iOS devices that
provides wireless control of networked Bose Professional system components. Personalized for each end
user's mobile device, various functions of the system can be adjusted:

« Volume levels and mute state
« Source selection

« Tone EQ settings

o Parameter set recall

The ControlSpace Remote app is available as a free download on the App Store or Google Play™ store.

ControlSpace Remate - -— x
Demo Mode o]
folume & Source Contro

e g
Bar Dining
83% B3I%
MUTE MUTE
Audio Controls
-

ControlSpace Remote App Control Panel Example

Getting Started

To get started using the ControlSpace Remote Builder desktop app:
1. From PRO.BOSE.COM, download and install the ControlSpace Remote Builder desktop app to your
computer.

2. From the Google Play™ or App Store, download and install the ControlSpace Remote app to your
mobile device.

3. Ensure that your Android™ or iOS device is connected to the same Wi-Fi® network as your Con-
trolSpace/PowerMatch devices.

Trademark Notices

Bose® ControlSpace® and ControlSpace® Designer™, are registered trademarks of Bose Corporation.
Android™ and Google Play™ are trademarks of Google Inc.

App Store®is a service mark of Apple Inc.

Wi-Fi®is a registered mark of the Wi-Fi Alliance.

All other trademarks are the property of their respective owners.



http://pro.bose.com/

ControlSpace Remote Builder 2.4 User Guide

ControlSpace Remote Builder Window

The ControlSpace Remote Builder window contains four key elements: a menu bar, a toolbar, the Pro-
ject/Properties panel, and the Control Panel canvas.

Contrpllipace Rempbe bl = o W
g 3 P |—— Toolbar

Grouga SITE MAME {}

Faepmrd ety

P pmrieriatl

[~ ]

-
Project/Properties — — Control Panel
Panel Canvas
. COLLECTIONY
Froject Froperses -

ControlSpace Remote Builder window elements

Menus
The menus located in the menu bar contain the main commands in ControlSpace Remote Builder.

File Menu

File = Edit Layout Toolz Help

B, Open CSP File...

& New Remote app File... Cirl+N
) Open Remate app File... Cirl+0
[%  Save Remote app File... Chrl+5

[%,  Save Remote app File As...

P Update Remote app IP Addresses...

Exit Cr+Q

The File menu includes the following options:
« Open CSP File - opens a window for browsing to an existing ControlSpace Designer software project
file.

« New Remote app File - opens a window in which you can select a template or blank panel to use for
building a new Remote app control panel.

« Open Remote app File - opens a window for browsing to an existing Remote app file.

« Save Remote app File - initially opens a window for naming the current Remote app file and browsing
to a location to save it. Subsequent selections of this menu option will immediately save changes dir-
ectly to the previously selected file location.

« Save Remote app File As - opens a window for renaming current Remote app file and browsing to a
location to save it.
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« Update Remove app IP Addresses - opens a window for updating the IP addresses of each device in
the open project file.

Edit Menu

Edit Layout Tools Help

& Unde Cirl+Z
Redo Chrl+y

5  Undo List...
Cut Chrl+x
Copy Cirl+C

o Paste Chrl+v

4 Delete Del

The Edit menu includes the following options:
« Undo - erases the last change and reverts to the previous state.

« Redo - reverts the effects of the undo action.

« Undo List - opens the Undo/Redo window

« Cut - removes the selected item and copies it to the clipboard (standard Windows editing function).
« Copy - copies the selected item to the clipboard (standard Windows editing function).

« Paste - pastes the contents of the clipboard (standard Windows editing function).

« Delete - removes the selected item.

Layout Menu

Layout Tools Help

'm; Bring To Front Ctrl+F

®  Bring Forward Ctrl+5hift+F
‘o Send To Back Cirl+B

®  Send Backward Ctrl+Shift+B
=  Align Left Chrl+Left
== Align Right Ctrl+Right
1 Align Top Ctrl+Up

ol Align Bottom Ctrl+Down
mm Align Horizontal Center Ctrl+Home
& Align Vertical Center Ctrl+End

®  [Distribute Horizontally Alt+Right

4  Distribute Vertically Alt+Down

The Layout menu includes the following options:
« Bring to Front - moves the selected object to the top layer.

« Bring Forward - moves the selected object one layer toward the top.
« Send to Back - moves the selected object to the bottom layer.
« Send Backward - moves the selected object one layer toward the bottom.

« Align Left - aligns selected objects relative to their left edges.
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« Align Right - aligns selected objects relative to their right edges.

« Align Top - aligns selected objects relative to their top edges.

« Align Bottom - aligns selected objects relative to their bottom edges.

« Align Horizontal Center - aligns selected objects relative to their horizontal centers.
« Align Vertical Center - aligns selected objects relative to their vertical centers.

« Distribute Horizontally - distributes selected objects evenly along the horizontal axis

« Distribute Vertically - distributes selected objects evenly along the vertical axis

Tools Menu

Tools | Help
[ Layout...

Canvas...

&1

Go Online...

., Send to Mobile Device...

The Tools menu includes the following options:
« Layout - opens the Layout dialog which allows you to add/delete collections and panels.

« Canvas - opens the canvas setup dialog.
« Go Online - connects to a ControlSpace network.
« Send to Mobile Device - transmits the control panel file to a mobile device.

Help Menu

Help

() Help Topics...

(1) About ControlSpace Remote builder...

The Help menu includes the following options:
« Help Topics - Opens online Help.

« About ControlSpace Remote Builder - opens a dialog which reveals the software version number.

Toolbar
The toolbar contains icons/buttons that provide the following functions:

Open CSP file - Opens a window for browsing to an existing ControlSpace Designer software pro-
ject file

New Remote app File - Opens a window in which you can select a template or blank panel to use
for building a new Remote app control panel

Open Remote app File - Opens a window for browsing to an existing Remote app file

Save Remote app File - Initially opens a window for naming the current Remote app file and brows-
ing to a location to save it. Subsequent selections of this tool will immediately save changes dir-
ectly to the previously selected file location

B & &

Cut

&
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r&, Copy

L-E-I-‘ Paste

E Delete
Undo
Redo

Undo List - Opens Undo list window

o—a

.

Edit Mode - Enables/disables Edit mode

Layout - Opens "Layout Tool” on page 11

Canvas - Opens "Canvas Setup Properties” on the next page

B o

Go Online
Eﬁ Send to Mobile Device - Sends file to mobile device

Project/Properties Panel

Selecting the Project tab displays a tree view of devices and controls in the opened project file. Selecting
the Properties tab displays properties for a selected object on the canvas.

Control Panel Canvas

This canvas is the workspace for creating control panels. The size, shape, orientation, and other properties
of the Canvas is set using the Canvas Setup Properties tool in the toolbar.

See "Canvas Setup Properties” on the next page for more details.
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Canvas Setup Properties
The Canvas Setup window allows you to define the size and features of the control panel you are creating.

Canvas Setup A
Dwevice: | User Defined -
gize: [6 | ke Cancel
Aspect Ratio: | 16:9 -
Lirsts
Oientation: | Portrait - {®) Inches
Top Slot: | Standard Toclbar = i) Centimeters
Bottom Slot: | Statusbar -
Skin: ht -
Ly Cushomize
Accent: | Blue - Device List
4 center Controls Horizontally
Centering will be applied when this dialog is dosed

Canvas Setup window

The Canvas Setup window includes the following properties:

« Device - Determines the canvas Size and Aspect Ratio for the selected device. The drop-down menu
includes several pre-populated options, as well as any devices added using the Custom Device List but-
ton (described later in this topic). The User Defined option allows you to set values such as size and
aspect ratio manually.

NOTE: Size and Aspect Ratio can only be adjusted manually when "User Defined" is selected as the device.

« Size - Diagonal screen dimension of the selected device.

« Units - Specifies whether the measurement unit in the Size field is in inches or centimeters. This option
appears on the right side of the window.

« Aspect Ratio - The proportional relationship between the width and height of the screen on the selec-
ted device.

« Orientation - Changes the orientation of the screen between portrait and landscape.
« Top Slot/Bottom Slot - Places the Standard Toolbar, Minimum Toolbar, Statusbar, or no toolbar
(None) in the top/bottom border of the Canvas.

o Standard Toolbar- The left-hand end of the toolbar has a field for naming the site where the panel
will be used. The SITE NAME is entered using the Layout window. The right end of the toolbar
includes an Online/Offline link indicator and a Setup information button.

SITE MAME o

o Minimum Toolbar- The Minimum Toolbar includes the Online/Offline link indicator and the setup
information button.

o

o Statusbar- The Statusbar indicates which collection of panels has been selected. The dots indicate
how many panels are in the collection (there is always one blank panel). Click the left/right arrows to
view other panels - the highlighted dot will move left/right accordingly. If multiple collections exist,
you can click COLLECTION to open a list of panel collections and select a different one.

OMLECTIONE
w

o None - Removes the toolbar from the canvas.
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Skin - Selects a Light or Dark Skin for the panel.

Accent - Selects an accent color (Black, Blue, Green, Pink, Red, or Yellow) for the controls dragged
into the panel.

Center Controls Horizontally - When this check box is selected, the controls are centered in the work-
space. This applies only when creating custom control panels.

Units - Specifies units of measurement as either inches or centimeters.

Customize Device List - This button appears on the right side of the Canvas Setup window, and opens
the Custom Device List dialog box, in which you can create device definitions other than those in the
Device drop-down menu.

Custom Device List *

Create Device Definition

Hame

Déagonal Length inches
Porirait Aspact Rakio

Hasight
Whath Load From Extemal Rl
Ratie | fvvabd b 1gnere duplicates

O

Custom Device List dialog box

-10 -
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Layout Tool

The Layout tool manages the collections and control panels being created in ControlSpace Remote
Builder software. Initially, the Layout tool provides one collection (COLLECTIONT) with one blank panel
(Home). You can add additional blank panels from the template list to create custom layouts.

Layout n

Site: | SITE NAME | [ ok ]
~ - Blank Panel Cancel
~ [f COLLECTION1
fL Home
Add Collection

Delete Collection

Add Panel

Delete Panel

Move Up

Move Down

Edit Title...

Initial Layout tool content

The Layout tool provides the following control buttons:
« OK - Stores changes and closes the tool.

« Cancel - Closes the tool without making any changes.

« Add Collection - Adds another collection to the list.

« Delete Collection - Removes the selected collection from the list.

« Add Panel - Adds another control panel to the list

« Delete Panel - Removes the selected control panel from the list

« Move Up - Moves the selected item up one line in the list.

« Move Down - Moves the selected item down one line in the list.

« Edit Title - Allows changing the title of the selected collection or control panel.

-1 -
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File Types

This application is compatible with the following file types.

File Type Description

.CSp ControlSpace Designer project file.

.cpf Custom control panel file.

.Cpz A packaged file that includes data from a control panel file (.cpf) and its associated Con-
trolSpace Designer project file (.csp).

-12 -
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Creating Panels Using Templates

Creating Control Panels

1. Open the Remote Builder app on your computer using the desktop icon.
2. In the Remote Builder Window, click the Open CSP File tool.

Coarirglpare Ramaoge Budder - a *
Fig ©Gsn  Lepset Tl Help
Y ™y = = i
ARG TE QS R
e SITE NAME e
Farampterien
EOGroup
FaramarterieTlinty
Graphict
Wyriem
. - COULECTIONT
Proge | Progermes

Open CSP File tool

3. From the dialog window, select the ControlSpace Designer project file you created and click Open.

Open Controlipace Designer File w
d « Public Doc... » ControlSpace Remote builder "

o
Organize = Mew folder m a

A

Bl This PC Name Uate modified lype
BB Desktop ﬁ Demo.csp
& Documents
4 Downloads
gt Music
&= | Pictures

! Videos

‘i Windows (C:)

L 4

File name: | Demo.csp w | | C5D Filles (*.csp) w

Selecting a Project File

4. Check that all the devices and controls in that project are listed in the window.

-13 -
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C oerdealhppse Hamobe bsldar - (i k.

Fig g

IRBE o

g SITE NAME o]

Toolkk Help

g [ 03 [

W Farieterii
1 Tl Ralaems

LRLLECTION

Project File Devices and Controls

5. Before you start creating a control panel, make sure Edit mode is selected.
NOTE: Edit Mode must be enabled in order to create a control panel.

Contegtipsre Ramobe buslder - m o

r mEe e

SITE NAME [

Fie [dn  Lawour Toolkk Help

LRLLECTION

Edit Mode Selected

6. In the toolbar, click the Canvas tool. Make your selections and click OK.

NOTE: See "Canvas Setup Properties” on page 9 for more information.

-14 -
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RERE . TmRe e
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B 1
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Galawy Ted 51 -]
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T Flots | Google Prodl § Comtemrters
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LRLLECTION

o Fepert ‘| Praserme
Selecting canvas size for your device

7. In the toolbar, click the Layout tool.

Cprsirgtipace Perveste busdder - - ] *
Fie (3 Lyt TodE Heag
e % Ty ur s M
"3.'.- g Lo Lo 3 . L8 E‘s F
Democip
FRALISON 1 SITE NAME el
BB
g Layeut a
(]
B e [ =3
P
g |~ - Sask Paal Cararl
% w i CpLLECTIONY
LA
ke
- - COLLECTROML
" Penjen 1 Fropermes

Clicking the Layout tool

8. Using the Layout window, add a template to the workspace. For example, click Home below
COLLECTIONT1. Click Add Panel, select a template and click OK.

-15 -



ControlSpace Remote Builder 2.4 User Guide

MMl ld RREIFNEQ Q-

Pemc.csp |
PALZE0N 1 SITE MAME fel
R0 1 Fader 1 Mute 1 Salector
Graupd 1™
FarametedSy L " -
REGnoups n
Farameterty
Gaphes Ste: [S3TE susee =]
Syvtem w - Blank Pane Cangel
i v 0 courcnen
lio eene | | addcotecsen
s 1 Fader 1 Migte 1 Sal.
Dudebe Colleciion
Ddebe Faned
Mowee Up
Hewve Deswn

Bl Tithe....
P

T froject | ) Properties COLLECTION1

Selecting a control panel template

il ControlSpace Remote builder - - m] *
File Egit Layout Tools Help
M % ™ Y M 73| m
% Lc I-—Ia Eﬂ Jc @ @ Lo Go |t .!“ r‘{a o r
Demo.cip
PMAZSON 1 SITE NAME i
Select a Template B8 1 Fader 1 Mute 1 Selector
[ - Blank Panel a |
1 Fader 1 Mute 1 Sedector
1 Fader 1 Mute Cancel
1 Fader
1 Selector
2 Fader 2 Mute 1 Selector
2 Fader 2 Mute 2 Sedector
2 Fader 2 Mute
2 Fader
2 Parameter Sets
4 Parameter Sefs
L& Parameter Sets *Ii
- = COLLECTION1
o Project | Propertes =

Placing the template in the workspace

9. Drag controls to the pre-defined locations on the control panel template (see the following
examples).

NOTE: To verify the operation of any control panel feature such as a slider or drop list, be sure to disable the Edit

mode.

-16 -
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w1 ControlSpace Remote builder - - o x
File Edit Layout Tools Help

BRRREB»-RERRAINBRE R

SITE NAME = {}
1 Fader 1 Mute 1 Selector

~ PM4250N 1
» Analog IO
Digital /0
w ESP-EBO1
s Analog /0
» Digital IO
~ Blocks
+ Left Gain
» Right Gain
~ Source
W List
HF Tonega L
i} Tonegar
3 Mic Gain
Groups
ParameterSats
RCGroups
ParameterSetLists
Graphics
» System
Links

< COLLECTIONL b
LR I

F project [ Properties

! ControlSpace Remote builder - - O x
File Edit Layout Tools Help

BRRBBM%HREERRRIIBRR B

SITE NAME @ £}

¥ project [ Properties

Dragging a Source list to the Drop List

it ControlSpace Remote builder - - m} X

BRRRBHEEE RRRHBRE R

~ PM4250N 1 SITE NAME = 4}
+ Analog 1/

1 Fader 1 Mute 1 Selector

Digital 1/0

~ ESP-880 1
+ Analog 1/0
» Digital I/0

+ Blocks

¥
3
¥

% project (3 Properties I I

! ControlSpace Remote builder - - o x
File Edit Layout Tools Heip

BREBBHARBLEURRBREBLERE

SITE NAME @ £}

F project [ Properties

Dragging a list of Parameter Sets to the Drop List

-17 -
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Dragging the group volume gain to the slider

To change volume limits on a slider, select the slider and click the Properties tab. In this pane you can

set the maximum and minimum limits and select Percent or dB for units.

1 ControlSpace Remnobe builder - - [m] x o Controfipace Remote busldes - = ]
File Ednt Layout Took Help Fle Edit Lasyout Tooks Help
™ . & ™ FR e i @ [y o A [T X B | I
BLEEBBH%EEERRLREPBLE S K B33 0E % 3 26 Ig Q&
PAAZSN 1 SITE NAME e s pamason 1 | SITE NAME o)
ESPa01 1 Fader 1 Mute 1 Sebector > SR80 1 1 Fader 1 Mute 1 Selector
Groups ¥ Groups
Parameterieti ¥ Paameierien b
R Groups RCGeoups
~ ParamaterSetlian ~ Pasmeterietlicts -
T Plet st 2 W Poet List 2
W et lin 3 W et Lint 3 Three Room
Gemphics ¥ (Graphicy
Sywtem ¥ System Mornng
Linis ¥ Links
Lunch
Darurier
Mute All
—m——— ——
? Prapet -: srogartier COLLECTTONL :; Praject ! Propertes COLLECTION]
s & ]
Dragging a Parameter Set List to the Drop List
it ControlSpace Remote builder - - o X il ControlSpace Remote builder - - u] X
File Edit Layout Tools Help File Edit Layout Tooks Help
BB HEEERRR EEBR &K BB -LEEERERFBR&RK
Demo. ] Dem
[ ,,H‘:SW SITE NAME o) = mﬁml SITE NAME fo]
Analog /0 3 Analog /0
Dioal [0 1 Fader 1 Mute 1 Selector T 1 Fader 1 Mute 1 Selector
~ ESP-880 1 T ~ ESP-830 1 R
Analog /0 3 Analog /0
Digital /0 » Digital 1/0 Volume
Blocks ) Blocks 8%
~ Groups ~ Groups
~ Volume ~ Volume
4 Level 4 Level
% Mute %, Mute
ParameterSets s ParameterSets
RCGroups ROGroups
ParameterSetlists ParameterSetiists
Graphics » Graphics
System 3 Systsm
Links + Links
—— ———
o Project [ Properties :)OLLE"CTI:JN: & project [ Properties nCOu£i.'l1:)N1
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ConteeiSpaoe Rermate bulbder -

- o0 =
File Eda  Leyoat  Tooh  Help
M L] =l [l 1 [ i
%.::{._-- » L@ '@ Lo Le :hl-r'ﬁq ?-:
Shdar - B9800 1 ; Volame
SITE NAME o
kS Width
I Fader 1 Mule § Selecion
Feight -
Wax |13 L —— (tord
Min |50 a8 O Horimntsl BT
Un Percesk T
il oy
Tex? | ‘olurme
= DOLLECTION]
Project ] Praperped

Volume Properties

10. To add another panel, click the Layout button, select COLLECTION1 and click Add Panel.

e = = Foa T
BRRARB »RCEEURRE QEL e R
Dema.usp
e SITE NAME o
E5P-B30 1 1 Fader 1 Mute | Seletor
Layoun oss=T
Sitnc | SITE HAME [+ —
%
v . Hank Pyee Cancel
v [couemom ]
i@ Home A Colescton ()
g 1 Facer 1 Myt 1 Sl
Dibete Colertion
Dbebe Pane
Mot L
Hiave fian
Dt T,
= - COLLECTICN
o Bragedt 1 Properties -

Locating the Add Panel button

11. Select a panel template and click OK. Repeat this to add as many panels as needed. Click the left
and right arrows in the Status bar to scroll through the panels.

-19 -
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Select a Template

- Blank Panel

1 Fader 1 Mute 1 Selector
1 Fader 1 Mute

1 Fader

1 Selector

2 Fader 2 Mute 1 Selector
2 Fader 2 Mute 2 Selector
2 Fader 2 Mute

2 Fader

2 Parameter Sets

4 Parameter Sets
L6 Parameter Sets

0K

Caneed

Layout

Site: | SITE NAME

- Blank Panel

w [ COLLECTIONL

% Home

A% 1 Fader 1 Mute 1 Selactor
i 1 Fader 1 Mute

oK
Cancel

Add Collection

Delete Collection

Add Panel

Dielete Panel

Move Up

Move Down

Edit Title...

Adding another panel template to the Layout

1 Comtrolipace Remote bulder - - ] *

File Edit Leyout Tookh Help
BBRE -

% B RBEB % &G

e 1 SITE HAME &

£ 1 Fader 1 Mute
Grosps

Far e beraels

RCGnsupt

Parpmaterieilists

Graphss

System

Landcs

= = COLLECTION]
o Projest |5 Properties ‘R

COLLECTIONT with one blank panel and two templates

NOTE: To change the COLLECTION Name, select COLLECTION1 and click Edit Title. Enter the new name and
click OK.

-20 -
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= S .
BERBE%GEELLREBEIYEILQ -
Eaaanon 1 SITE NAME L
ERg001 * Sader | Mube
Sie- | SETE MAME ] o
- flank Paned Cangel
v [ couECTIoNT
£ Home —— -
g 1 Fader 0 a
5 1 Fades
Canel
—
Hawe U
Mave Doen
Bt T
———
= a COLLECTION]
o Project I Propertes

Changing Name of COLLECTIONI.

12. To add another collection, select COLLECTIONT1 again and click Add Collection. COLLECTION2 is

added to the Layout.

Layout ﬂ
Site: | STTE NAME ok |
[« - Blank Panel Cancel
~ [ COLLECTIONL
% Home -
AL 1 Fader 1 Mute 1 Selector Add Collection
AL 1 Fader 1 Mute
# . Delete Collection
Add Panel
Delete Panel
Maove Up
Maove Down
Edit Title....

Layout n
Site: | SITE NAME | oK
[« Blank Panel Cancel
w [} COLLECTION1
h Home -
% 1 Fader 1 Mute 1 Selector
A% 1 Fader 1 Mute -
@ coLECTIONZ | |Delete Collection
Add Panel
Delete Panel
Maove Up
Maove Down
Edit Title...

13. To create more panels, add more templates or blank panels and drag-and-drop controls to them.

14. When you are done, click Save Remote app File.

ControlSpace Remote builder -

File Edit Layout Tools

BRI HeREEE

Save Remote app File button

Help

(o (& B I

-21-
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Sending to a Mobile Device

To send a panel to your mobile device, make sure your PC and mobile device are connected to the same
Wi-Fi® router.
1. Launch the ControlSpace Remote app on your mobile device.

2. Touch the Settings icon.

Demo Mode @

BOSE PROFESSIONAL

pro.Bose.com

This file demonstrates the type of
controls a user has access to with
Bose Professional Audio Systems.

For more information please visit:
http://pro.Bose.com

Please Note:

ControlSpace Remote only works with
Bose Professional Audio Systems and
will not provide control of any Bose
Consumer products such as LifeStyle
and SoundTouch systems.

Audio Controls
L]

Remote App Settings icon

3. In the pop-up menu, touch Receive.

Demo Mode <
BOSE PROFESSIONAL

pro.Bose.com

This file demonstrates the type of
H AN

manbeala = simae s mmame b e
Setup

About ConfrolSpace Remote...
Project Information. .
Network Status...

Receive...

FIoasDc ivwee,

ControlSpace Remote only works with
Bose Professional Audio Systems and
will not provide control of any Bose
Consumer products such as LifeStyle
and SoundTouch systems.

< Audio Controls >

Selecting Receive in the Remote app

The Receive Control Panel dialog box appears and reveals the IP address that you will use in Step 5.

-22 -
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Receive Control Panel...
Mobile IP Address:

192.168.0.3

Receive Control Panel Dialog

4. On your computer, in the ControlSpace Remote Builder toolbar, click the Send to Mobile Device

icon.
| Do pabre Feie Busdder - - a b4
Fde Edn  Leyoit  Toals  Help
; - ~ =
Emgm!aﬁ.aaagamm@ﬁi
e PN 1 Lakeside Lounge o 3
¥ ESP-EED N
g DAning Area
» Parmateriats Lunch W
ROGraups
» Paremenersetlans Velime
* Geaphey %
* Gyibain
¥ Leninx (I)
MUTE =]
' ' COLLECTTONL
T opreier [ Froperbes - 5 sa i

Send to Mobile Device
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5. In the Send to Mobile Device dialog box, enter the IP address from the Receive Control Panel dialog
box on the mobile device and click OK.

Send to Mobile Device £

1) Configure wirsless netwark for PC and mobile device.

2) Select Receive.., from Setup menu on mobile device.
3) Enter IP address shown on mobile device in fields balow,
4) Click QK.

Cancel

Mobile Device IF Address

BEE s |aea =] o (5[ (2

The control panel file will be transferred to the mobile device.
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Creating Custom Panels

Creating Custom Layouts

You can create your own customized control panels by using the tools and options available in Con-
trolSpace Remote Builder. From the Project tab, you can combine labels, images, frames, and regions to
create a customized layout. The Layout menu functions can help you position the objects you placed on
the canvas.

ControlSpace Remaote builder O W
File Edit Layour Toals Help
.'_5 Y N B :h‘_ -|:| -_r!‘ '
Dema.csp ) i
~ PMAZSON 1 SITE NAME {3

Analog /O

Drigital IS0
ESP-880 1
Groups

ParameterSets

RCGroups

= CODLLECTIONL
1 Properties o

Locating Graphics
Importing Backgrounds

You can import backgrounds to place maps, floor plans, or other graphics of a venue into the workspace.
To place a floor plan or map on the canvas:
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1. On the Project tab, expand the Graphics group.
2. Drag the Image icon onto the canvas.

ControlSpace Remote builder - - O b
File Edit Leyour Tools Help
o Y Wy L ™ Y 2| [ 1
. BEE5S & o g 3 F
Demo.csp
4325 SITE NAME o

= PMA250N 1
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Digital I/0

ESP-880 1
Groups

ParaMmELErSets

~ Graghics
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=, Image 0
— ot
L rFrame
"% Region
Syste
fks
= COLLECTIONL
Project i Properties i

Dragging Image icon into the Canvas

3. In the canvas, double-click the Image icon. The Properties tab will automatically be selected.

On the Properties tab, navigate to the file you want to import from your computer and click Open.
The file will appear on the canvas.

ControlSpace Remote builder - O X
File Edit Layout Tools Help
% - 3 (B w e p _.;\; @ iiu [ I-_ F
i SITE NAME 3
i |68 Widtn (128
3 Height |68

l mage |- fimages/default.png

J Use a5 backgrownd image

Maximum cached width 3048 -

- COLLECTIONL
Froject i Propeimes ™

Searching for an Image

5. Re-size the image by dragging the handles on the right side and bottom of the image frame. Altern-
atively, set the image as a background image by selecting the Use as background image check box
and adjusting the available parameters, which are listed below.
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ControlSpace Remote builder - O

=

o

Layour Tools Help

™ ™ 1 ||:?;. - | [ |—. E- r

SITE MAME i

Height |0

mage images/default.png

-] Use a5 backgrownd image

Mode | Pad -

o B properiie COLLECTION1
« Mode - Specify how to adjust the background image size with respect to the canvas. Options include:

o Stretch - Fits the width and height of the image to match the canvas size. This option does not pre-
serve the aspect ratio of the original image.

o}

Preserve aspect and fit - Fits the larger image dimension to the canvas size, while preserving the
aspect ratio of the original image.

o Preserve aspect and crop - Fits the smaller image dimension to the canvas size, while preserving
the aspect ratio of the original image.

o Tile - Repeats the image horizontally and vertically to fill the canvas. This option preserves the size
and aspect ratio of the original image.

o Tile Vertically - Fits the image width to the canvas size, then repeats the image vertically to fill the
canvas. This option does not preserve the aspect ratio of the original image.

o Tile Horizontally - Fits the image height to the canvas size, then repeats the image horizontally to fill
the canvas. This option does not preserve the aspect ration of the original image.

[e]

Pad - Centers the image on the canvas. This option preserves the aspect ratio of the original image.

« Opacity - Use the slider to adjust the opacity of the background image.

« Maximum cached width - Set the maximum cache width used for the background image. Larger cache
size allows for higher-resolution images, but may have a longer load time. Smaller cache size may allow
image to load faster, but display with a lower resolution.

Adding images

ControlSpace Remote Builder software includes an image library of sources and zones that may be used to
create your custom control panel. Library images are available in five colors: Blue, Green, Pink., Red, and
Yellow.
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Zone Image Library

To place a library image on the canvas,

1. Follow Steps 1-3 of the Importing Backgrounds procedure (above) and drag the image icon into the
canvas.
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2. On the Properties tab, navigate to the directory for the Sources and Zones folders.

JOuUrces

Y -

Locating Sources and Zones images

3. Open the folder that corresponds with the color you wish to use.

Choosing colored images

-29 -



ControlSpace Remote Builder 2.4 User Guide

4. Select animage and click Open. The image will appear on the canvas.
ontrolSpace Remote builder
| B BEBMHEEW MQ o iy @ r

SITE NAME i

- 11

COLLECTION]

Proiect
T -

Selected Blue Image on Canvas
NOTE: Image colors match the Skin accent colors selected in the Canvas Setup properties.

5. Re-size the image by dragging the handles on the right and bottom edges of the image frame.

Adding Text Frames & Labels

Use the Label option in the Graphics group to place a text field on other graphics and create labels or text
strings. Resize labels by dragging the handles on the right and bottom edges of the frame.

ControlSpace Remote builder - a >

File Edit Layout Tools Help
i o ™ e = =

S EREN IR R RE g LQ F
Demo.csp
> PM42S0N1 SITE NAME {:}

ESP-880 1

Groups

FarameterSets
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ParameterSetlists

Label

= COLLECTION1
Project i Properties -

Dragging a Label into the Canvas

Double-click the label in the canvas or click the Properties tab to reveal the label properties.
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ControlSpace Remote builder - O x
File  Edit Layout  Tools Help
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Scale |10 -
Calor .
Label
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Label Properties

Label properties include the following parameters:
« X/Y - Specifies the X/Y coordinates of the upper-left corner of the label.

« Width/Height - Specifies the width and height of the label.
« Text - Provides an area in which to enter text for the label.
« Align - Positions the text left, right, or center.

« Scale - Changes the size of the text.

« Color - Changes the color of the text.

Adding a Frame

Use the Frame option in the Graphics group to add a rectangular shape to your design. Resize frames by
dragging the handles on the right and bottom edges of the frame.
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ControlSpace Remaote builder - O x
File Edit Layout Tools Help
o B ™M I m B
B RBEM %R dRLRR|IGEHLE SR

Demo.csp
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. . COLLECTION1
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Dragging a Frame into the canvas

Double-click the frame in the canvas or click the Properties tab to reveal the frame properties.

ControlSpace Remote builder - a >

File Edit Layout Tools Help

BRREBHRLELRBRRIELR @ K

Frame SITE NAME e
x[15 ] wiem [131
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Field Color . .
Border Colar r -
Border Width 0.5 -

- - COLLECTION1
o Project |5 Properties .

Frame Properties

Frame properties include the following parameters:

o« X/Y - Specifies the X/Y coordinates of the upper-left corner of the frame.
« Width/Height - Specifies the width and height of the frame.

« Field Color - Changes the fill color.

« Border Color - Changes the color of the border.

« Border Width - Changes the line weight of the border.
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Adding a Region

Use the Region option in the Graphics group to add a customizable polygon to the canvas. A region can
be linked to an existing control panel. Reshape regions by dragging the handles on the edges of the frame.
To add another handle, press and hold the Ctrl key, place the cursor where you want the handle, and then
click. To remove a handle, press and hold Ctrl+Shift, and then click the handle you want to remove.

Contrel5pace Remaote builder

File Edit Layout Tools Help
) ™ ™ I
mBRBM % 6 o Lo e
Demo.csp
PRAS2S0N 1 SITE NAME
ESP-B80 1
Groups
Parameterbets
RCGroups
ParameterSetlists
» Graphics
4 labe
= Image
[} frame
"1 Region
System
nks
Project [ Properties

g R r

COLLECTION1
.

- a x

Dragging a Region into the canvas

Double-click the region in the canvas or click the Properties tab to reveal the region properties.

- 33 -



ControlSpace Remote Builder 2.4 User Guide

ControlSpace Remate builder - - | X

File Edit Layout Tools Help
R RBEB Rl ¥R I§HILE -
. . Httiﬁ“. : SITE NAME 3
X %0 Width |115
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Border Color |_
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Path

COLLECTION]

':2 Project __E Properties

Region Properties

Region properties include the following parameters:
« X/Y - Specifies the X/Y coordinates of the upper-left corner of the region.

« Width/Height - Specifies the width and height of the region.
« Field Color - Changes the fill color.

« Border Color - Changes the color of the border.

« Border Width - Changes the line weight of the border.

« Path - Links the region to an existing control panel.

Creating Custom Controls

Project controls listed in the tree view can be dragged into a custom panel design. The appearance of but-
tons, sliders, and drop-lists can be changed using their individual properties.
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Custom Buttons
1. From the Project tab, drag a button into the canvas.
2. Using the handles on the right and bottom edges, resize the button.

ControlSpace Remote builder - a *
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Dragging a Button into the Canvas

3. To access the button properties, double-click the button or click the Properties tab.

ControlSpace Remote builder - a x
File Edit Layout Tools Help
BRBBHREEUYRLAEGEEBE &R
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Main Text Images
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Viewing the Mute Button Properties
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4. Adjust the properties as desired, using the options available in the tabs:
« Main tab:
o X/Y - X/Y coordinates of the upper-left corner of the frame.

o Width/Height - width and height of the button.
o Mode - selects how the button appears: Text, Image, or Text+Image (both).
o Border - when checked, places a border around the button.

« Text tab: (only active in Text and Text+tlmage modes)
o Text - allows text entry for button labels when mute is off or on.

« Images tab: (only active in Image and Text+lmage modes)
o Image - specifies whether to use the default icon or a custom image.
o Off - specifies image when mute is off.

o On - specifies image when mute is on.

Custom Sliders
1. From the Project tab, drag a slider into the canvas.

2. Using the handles on the right and bottom edges, re-size the slider.
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Dragging a Slider into the Canvas

- 36 -



ControlSpace Remote Builder 2.4 User Guide

3. To access the slider properties, double-click the slider or click the Properties tab
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Viewing the Slider Properties

4. Adjust the properties as desired:

X/Y - X/Y coordinates of the upper-left corner of the frame.

Width/Height - width and height of the slider.

Max - selects the maximum value on the slider.

Min - selects the minimum value on the slider.

Vertical/Horizontal - sets the orientation of the slider as vertical or horizontal.
Units - selects dB or Percent.

Color - selects the color of the slider.

Text - allows entry of a label for the slider.

-37-



ControlSpace Remote Builder 2.4 User Guide

Custom Drop-lists
1. From the Project tab, drag a list into the canvas.
2. Select the items you want in the list and click OK.
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Dragging a Drop List into the Canvas

3. Using the handles on the right and bottom edges, resize the drop list.
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4., Toa

ccess the drop-list properties, double-click the list or click the Properties tab.

ControlSpace Remote builder - a x
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Viewing the Drop List Properties

5. Adjust the properties as desired:
e« X/Y - X/Y coordinates of the upper-left corner of the frame.

« Width/Height - width and height of the slider.
« Align - positions the list Left, Center, or Right

« Border - when checked, places a border around the button.

Custom

RCGroups

1. In the Project tab, expand the device with the desired room controls. Click and drag the desired con-
trol(s) for one of the rooms onto the canvas. (Controls for standard room combiner blocks [StRC]

will

be under the Blocks item of the device.)

2. Create an additional panel for each room you want to add:

a.

b
C.
d

Click the Layout icon in the toolbar, or click Tools > Layout.
In the Layout window, select the desired collection, and then click Add Panel.
In the Select a Template window, select - Blank Panel, and then click OK.

In the Layout window, click OK. Below the canvas, there should be an additional dot in the
Status bar to indicate a new panel.

In the Project tab, expand the device with the desired room controls. Click and drag the
desired control(s) for one of the rooms onto the canvas.

3. Repeat Step 2 to create a separate panel for your room combining controls.

4. On the Project tab, expand the RCGroups item, and then expand the RCGroup with the desired
rooms.

5. Clic

k and drag the Combination Control for the RCGroup onto the canvas. This is the selector for

each room combination.
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. Click and drag the desired control(s) for each room you created in Steps 1-2 onto the canvas.

« Room Name - the name of the room in the RCGroup.
« Active Combination - a field that shows the names of the other rooms in the combination.

« Room Layout - an adjustable polygon representing the layout of the room. Click and drag a
handle on the edge of the layout to move it. Press and hold Ctrl and click an edge of the polygon
to add another handle at that location. Press and hold Ctrl+Shift and click a handle to remove it.

. To access the properties of an item in any of the panels, double-click the item or click the Properties

tab. Adjust the properties as desired.

RCGroup items have the following properties:

« RCGroup Name - the properties are identical to those of a label (see Adding Text Frames
& Labels in Creating Custom Layouts).

« Combination Control:
o Y -the Y coordinate of the upper-left corner of the selector frame.

o Height - the height of the selector frame.
o Side Margins - the width of the margin on either side of the selector frame.

« Room Name - the properties are identical to those of a label (see Adding Text Frames & Labels
in Creating Custom Layouts).

« Active Combination:
o Y -the Y coordinate of the upper-left corner of the frame.

o Height - the height of the frame.

o Side Margins - the width of the margin on either side of the frame.

o Color - the color of the text inside of the frame.

o Border Color - the color of the border of the frame.

o Border Width - the width of the border of the frame.

o Separator - the character(s) that separate the combined room names shown in the frame.
« Room Layout:

o X/Y - X/Y coordinates of the upper-left corner of the region.

o  Width/Height - width and height of the region.

o Opacity - the opacity of the region.

o Border Color - the color of the border of the region.

o Border Width - the width of the border of the region.
Other controls are described elsewhere in this help topic: Custom Buttons, Custom Sliders, Custom

Drop-lists, Custom Parameter Sets, Custom Parameter Set Lists, Custom Links, Custom Setup Button,
or Custom Remote Connection Indicator.
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Custom Parameter Sets

1. From the Project tab, drag a Parameter Set onto the canvas.
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Dragging a Parameter Set into the Canvas

2. Using the handles on the right and bottom edges, resize the button.
3. To access the properties, double-click the button or click the Properties tab.
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Viewing the Parameter Set Button Properties
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4. Adjust the properties as desired:
e X/Y - X/Y coordinates of the upper-left corner of the frame.

« Width/Height - width and height of the button.

« Mode - selects how the button appears: text, or text+image.

« Border - when checked, places a border around the button.

« Text - in Text Mode, allows text entry for a button label.

« On/Off - in Image Mode, allows an image selection for both on/off states of the button.

Custom Parameter Set Lists
1. From the Project tab, drag a Parameter Set List onto the canvas.
Using the handles on the right and bottom edges, resize the button.
To access the properties, double-click the button or click the Properties tab.

A wN

Adjust the properties as desired:
e« X/Y - X/Y coordinates of the upper-left corner of the frame.

« Width/Height - width and height of the button.
« Align - selects the horizontal alignment of the text in the button.
« Border - when checked, places a border around the button.

Custom Links
1. From the Project tab, drag a control panel from Links into the canvas.
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Dragging a Link into the Canvas

2. Using the handles on the right and bottom edges, re-size the button.
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3. To access the properties, double-click the button or click the Properties tab.
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Viewing the Panel Link Properties

4. Adjust the properties as desired:
e« X/Y - X/Y coordinates of the upper-left corner of the frame.

« Width/Height - width and height of the button.

« Mode - selects how the button appears: text or image.

« Border - when checked, places a border around the button.

« Text - in Text Mode, allows text entry for a button label.

« Image - in Image Mode, allows selection of an image to use on the button.
« Path - links the button to an existing control panel.

Custom Setup Button

1. From the Project tab, drag a Setup Button from System onto the canvas.

Dragging a Setup Button into the Canvas

2. Using the handles on the right and bottom edges, resize the button.
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3. To access the properties, double-click the button or click the Properties tab.
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Viewing the Button Properties

4. Adjust the properties as desired, using the options available in the tabs:
« Main tab:
o X/Y - X/Y coordinates of the upper-left corner of the frame.

o  Width/Height - width and height of the button.
o Mode - selects how the button appears: Text, Image, or Text+lmage (both).

o Border - when checked, places a border around the button.

« Text tab: (only active in Text and Text+lmage modes)
o Text - allows text entry for a button label.

« Images tab: (only active in Image and Text+lmage modes)

o Image - specifies whether to use the default icon or a custom image. If you choose Custom,

browse to your desired image using the field that appears below the drop-down menu.
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Custom Remote Connection Indicator
1. From the Project tab, drag a connection indicator button from System onto the canvas.
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Dragging a Connection Indicator Button into the Canvas

Using the handles on the right and bottom edges, resize the button.
3. To access the properties, double-click the button or click the Properties tab.

ControlSpace Remote builder - - ] x
File Edit Layout Tools Help
RREBHBREBEWREREGNBLEE K

Button
: SITE NAME e’

Kain Teat Images

x50 | Width -_9-:1

v[i66 | Heignt [35
Maode Image | [ Border

|

- - COLLECTIONI

o Project [ Properties .

Viewing the Button Properties
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4. Adjust the properties as desired, using the options available in the tabs:

Main tab:
o X/Y - X/Y coordinates of the upper-left corner of the frame.

o Width/Height - width and height of the button.
o Mode - selects how the button appears: Text, Image, or Text+Image (both).
o Border - when checked, places a border around the button.

Text tab: (only active in Text and Text+lImage modes)
o Text - allows text entry for button labels when the connection is off, on, or partial.

Images tab: (only active in Image and Text+lmage modes)

o Image - specifies whether to use the default icon or a custom image.

o Off - specifies image when the remote connection is off.

o On - specifies image when the remote connection is on.

o Partial - specifies image when the remote connection is partially active.
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